about summary refs log tree commit diff
path: root/ci/pipelines/pre-receive.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-21T17·40+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-22T22·27+0100
commit42413399630d015e74aa0e782f217dbc25ff9fe8 (patch)
tree5f84adba085482cd1f0345fb6868575afc60b8da /ci/pipelines/pre-receive.nix
parent098ca0da15fa31e13c1709e57dd371c47bfdfd47 (diff)
Define Buildkite pipelines corresponding to git server hooks
I think maintaining a 1:1 correspondence with the git server hook makes sense
right now. Let's try it out!
Diffstat (limited to 'ci/pipelines/pre-receive.nix')
-rw-r--r--ci/pipelines/pre-receive.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/ci/pipelines/pre-receive.nix b/ci/pipelines/pre-receive.nix
new file mode 100644
index 000000000000..9a30f271ed45
--- /dev/null
+++ b/ci/pipelines/pre-receive.nix
@@ -0,0 +1,11 @@
+{ pkgs, ... }:
+
+let
+  pipeline.steps = [
+    {
+      key = "lint";
+      command = "${pkgs.git-secrets}/bin/git-secrets --scan-history";
+      label = ":broom: lint";
+    }
+  ];
+in pkgs.writeText "pipeline.yaml" (builtins.toJSON pipeline)