about summary refs log tree commit diff
path: root/ci/pipelines/briefcase.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-21T17·40+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-22T22·27+0100
commit42413399630d015e74aa0e782f217dbc25ff9fe8 (patch)
tree5f84adba085482cd1f0345fb6868575afc60b8da /ci/pipelines/briefcase.nix
parent098ca0da15fa31e13c1709e57dd371c47bfdfd47 (diff)
Define Buildkite pipelines corresponding to git server hooks
I think maintaining a 1:1 correspondence with the git server hook makes sense
right now. Let's try it out!
Diffstat (limited to 'ci/pipelines/briefcase.nix')
-rw-r--r--ci/pipelines/briefcase.nix17
1 files changed, 0 insertions, 17 deletions
diff --git a/ci/pipelines/briefcase.nix b/ci/pipelines/briefcase.nix
deleted file mode 100644
index 95977ccb9a3a..000000000000
--- a/ci/pipelines/briefcase.nix
+++ /dev/null
@@ -1,17 +0,0 @@
-{ pkgs, ... }:
-
-let
-  pipeline.steps = [
-    {
-      key = "lint";
-      command = "${pkgs.git-secrets}/bin/git-secrets --scan-history";
-      label = ":broom: lint";
-    }
-    {
-      key = "build";
-      command = "nix-build . -I briefcase=$(pwd) --no-out-link --show-trace";
-      label = ":nix: build";
-      depends_on = "lint";
-    }
-  ];
-in pkgs.writeText "briefcase.yaml" (builtins.toJSON pipeline)