about summary refs log tree commit diff
path: root/buildHaskell/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-13T17·04+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-13T17·04+0100
commita4caaba901caee20db9946dd766608da9b6aed57 (patch)
treeeaa0fbf8a917e82c12c856ac32bfde14f992d1c4 /buildHaskell/default.nix
parent2da4b12266322a3cfb7aa31cc24cfa591eb4e3d0 (diff)
Document ghcExtensions argument
Missed documenting this the first time...
Diffstat (limited to 'buildHaskell/default.nix')
-rw-r--r--buildHaskell/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/buildHaskell/default.nix b/buildHaskell/default.nix
index 0b6a488b31..5958b1ea26 100644
--- a/buildHaskell/default.nix
+++ b/buildHaskell/default.nix
@@ -9,12 +9,12 @@
   };
 
   # Build a Haskell executable. This assumes a project directory with a
-  # top-level Main.hs. It also applies a few commonly used language extensions.
-  # Here is an overview of the arguments:
+  # top-level Main.hs.
   # - `name`: You can find the result at ./result/$name
   # - `srcs`: Will be passed to `srcs` field of `pkgs.stdenv.mkDerivation`.
   # - `deps`: A function that accepts `hpkgs` and returns a list of Haskell
-  #   dependencies.
+  # - `ghcExtensions`: A list of strings representing the language extensions to
+  #   use.
   program = { name, srcs, deps, ghcExtensions }: let
     ghc = pkgs.haskellPackages.ghcWithPackages (hpkgs: deps hpkgs);
   in pkgs.stdenv.mkDerivation {