about summary refs log tree commit diff
path: root/buildGo.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-11T09·54+0000
committerVincent Ambo <mail@tazj.in>2019-12-13T00·39+0000
commit57f37743c2e295b0404023587b92c517e5731a30 (patch)
treefe7009bbb4c8d3eab51bb2b68ff20370b1654b9b /buildGo.nix
parentc40e8a4061b033282031cd1a8d64df9a591aa694 (diff)
fix(buildGo): Ensure 'proto' libraries are overridable
Diffstat (limited to 'buildGo.nix')
-rw-r--r--buildGo.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/buildGo.nix b/buildGo.nix
index 366be770a9..b5a6ba2b3a 100644
--- a/buildGo.nix
+++ b/buildGo.nix
@@ -73,7 +73,7 @@ let
   '') // { goDeps = uniqueDeps; };
 
   # Build a Go library out of the specified protobuf definition.
-  proto = { name, proto, path ? name, extraDeps ? [] }: package {
+  proto = { name, proto, path ? name, extraDeps ? [] }: (makeOverridable package) {
     inherit name path;
     deps = [ protoLibs.goProto ] ++ extraDeps;
     srcs = lib.singleton (runCommand "goproto-${name}.pb.go" {} ''