about summary refs log tree commit diff
path: root/buildGo.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-12T03·14+0000
committerVincent Ambo <mail@tazj.in>2019-12-13T00·39+0000
commite60dfabc2122bbc29fc9832d1562826c08772442 (patch)
tree49f3ac39c886bc7d959ddb1cdacfab38114ee057 /buildGo.nix
parent57f37743c2e295b0404023587b92c517e5731a30 (diff)
feat(buildGo): Expose Go import path for packages
Diffstat (limited to 'buildGo.nix')
-rw-r--r--buildGo.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/buildGo.nix b/buildGo.nix
index b5a6ba2b3a..c03c30bef1 100644
--- a/buildGo.nix
+++ b/buildGo.nix
@@ -70,7 +70,7 @@ let
     mkdir -p $out/${path}
     ${srcList path (map (s: "${s}") srcs)}
     ${go}/bin/go tool compile -o $out/${path}.a -trimpath=$PWD -trimpath=${go} -p ${path} ${includeSources uniqueDeps} ${spaceOut srcs}
-  '') // { goDeps = uniqueDeps; };
+  '') // { goDeps = uniqueDeps; goImportPath = path; };
 
   # Build a Go library out of the specified protobuf definition.
   proto = { name, proto, path ? name, extraDeps ? [] }: (makeOverridable package) {