about summary refs log tree commit diff
path: root/boilerplate/clojure/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-05-04T11·32+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-05-04T11·32+0100
commit066b1441b29df2d9616eabc8680e912e912cbb07 (patch)
tree906f1a4415a7eff50d26fce39f5c36e309de7c6a /boilerplate/clojure/shell.nix
parent7a7c29d46ce1503a57f7a81512d11960ca0f72c8 (diff)
Support //boilerplate/clojure
While this is most likely incomplete or even erroneous, I'd like to start
supporting Clojure in this repository.
Diffstat (limited to 'boilerplate/clojure/shell.nix')
-rw-r--r--boilerplate/clojure/shell.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/boilerplate/clojure/shell.nix b/boilerplate/clojure/shell.nix
new file mode 100644
index 000000000000..0ea68aba4608
--- /dev/null
+++ b/boilerplate/clojure/shell.nix
@@ -0,0 +1,7 @@
+let
+  pkgs = import <nixpkgs> {};
+in pkgs.mkShell {
+  buildInputs = with pkgs; [
+    leiningen
+  ];
+}