about summary refs log tree commit diff
path: root/blog/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-09T23·28+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-10T13·27+0000
commit1fbdec0d6a9252c4787142dc428f096b54d02c32 (patch)
treefd773bc676554fccff5f32203cb117a08a4b170a /blog/shell.nix
parent1e75f709ee349ab564480e7ec6f358016548810c (diff)
Initialize //blog with lorri
To create new posts, I run...
```shell
hugo new name-of-post.md
```

While writing posts, I run...
```shell
hugo serve -D
```

I need hugo available on PATH environment variable, which lorri provides.
Diffstat (limited to 'blog/shell.nix')
-rw-r--r--blog/shell.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/blog/shell.nix b/blog/shell.nix
new file mode 100644
index 000000000000..d1b4f49942bc
--- /dev/null
+++ b/blog/shell.nix
@@ -0,0 +1,8 @@
+let
+  pkgs = import <nixpkgs> {};
+in
+pkgs.mkShell {
+  buildInputs = with pkgs; [
+    hugo
+  ];
+}