about summary refs log tree commit diff
path: root/blog/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-23T16·34+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-23T16·34+0000
commit2c28f85946538397e0a32ef334b525e5db29712c (patch)
tree11981872e137a8bfb55f0a2033dc1bda3ad80acf /blog/default.nix
parent7f37acf548307448c92bd567de096d5734ac6f0d (diff)
Start working on a blog
Attempting to write a blog where:

- The server is Common Lisp. Why? I'd like to learn Common Lisp.
- The blog posts can be written in Markdown.
- The package is developed and deployed using Nix.

Most of this is a learning exercise. The blog itself is something that I'd like
to use instead of Medium and other forums.
Diffstat (limited to 'blog/default.nix')
-rw-r--r--blog/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/blog/default.nix b/blog/default.nix
new file mode 100644
index 000000000000..7005cc648d00
--- /dev/null
+++ b/blog/default.nix
@@ -0,0 +1,15 @@
+{
+  depot ? import <depot> {},
+  universe ? import <universe> {},
+  ...
+}:
+
+depot.nix.buildLisp.program {
+  name = "server";
+  deps = with depot.third_party.lisp; [
+    hunchentoot
+  ];
+  srcs = [
+    ./src/server.lisp
+  ];
+}