about summary refs log tree commit diff
path: root/blog/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-09T13·27+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-09T13·27+0000
commitd206a2812fc07e9ae8af016d3dc9d24a8bcf0508 (patch)
treefd5ddddb62457a5f5b5e67f68c5156dcecee7da6 /blog/default.nix
parent2e0ad09a0275dd11e0e8b3db1cbd04e72b9d196c (diff)
Prefer hugo for blog.wpcarro.dev
Instead of creating my own static website generator, I'm trying Hugo. Huge is a
newer alternative to Jekyll. So far, I like what I see.

- Ignoring /blog/public since this is where `huge -D` generates the static
  assets.
- Using a TailwindCSS theme.
- Creating a dumby post about Emacs to test deployments.
- Deleting all Common Lisp and Nix code that powered my previous, half-baked
  blog.
Diffstat (limited to 'blog/default.nix')
-rw-r--r--blog/default.nix21
1 files changed, 0 insertions, 21 deletions
diff --git a/blog/default.nix b/blog/default.nix
deleted file mode 100644
index fd35570a322a..000000000000
--- a/blog/default.nix
+++ /dev/null
@@ -1,21 +0,0 @@
-{ pkgs, depot, briefcase, ... }:
-
-let
-  injections = pkgs.writeText "injections.lisp" ''
-    (in-package #:server)
-    (setq *path-to-posts* "${./posts}")
-    (setq *pandoc-bin* "${pkgs.pandoc}/bin/pandoc")
-    (setq *html-template* "${./src/index.html}")
-  '';
-in depot.nix.buildLisp.program {
-  name = "server";
-  deps = with depot.third_party.lisp; with briefcase.third_party.lisp; [
-    hunchentoot
-    cl-arrows
-    cl-ppcre
-  ];
-  srcs = [
-    ./src/server.lisp
-    injections
-  ];
-}