about summary refs log tree commit diff
path: root/blog/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-29T14·43+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-29T14·43+0000
commit5c9079a41059e077f2b71b68eb83ff9fcb2e38d1 (patch)
treedce7e3566b04213228fb3c92fc593ca18841d972 /blog/default.nix
parentfb9380ba268b3cd27372acadb87b14cc96163374 (diff)
Splice ./universe directory into ./
Manually merging:
- README.md: I added the description from universe/README.md into the heading of
  dotfiles/README.md.
- .envrc: dotfiles/.envrc was a superset of universe/.envrc
- .gitignore: Adding some of the ignored patterns from universe/.gitignore to
  dotfiles/.gitignore

Everything else here should be a simple rename.
Diffstat (limited to 'blog/default.nix')
-rw-r--r--blog/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/blog/default.nix b/blog/default.nix
new file mode 100644
index 000000000000..5359a0ab6f37
--- /dev/null
+++ b/blog/default.nix
@@ -0,0 +1,28 @@
+{
+  nixpkgs ? import <nixpkgs> {},
+  depot ? import <depot> {},
+  universe ? import <universe> {},
+  ...
+}:
+
+let
+  injectedPosts = nixpkgs.writeText "posts.lisp" ''
+    (in-package #:server)
+    (setq *path-to-posts* "${./posts}")
+  '';
+  injectedExecutables = nixpkgs.writeText "executables.lisp" ''
+    (in-package #:server)
+    (setq *pandoc-bin* "${nixpkgs.pandoc}/bin/pandoc")
+  '';
+in depot.nix.buildLisp.program {
+  name = "server";
+  deps = with depot.third_party.lisp; with universe.third_party.lisp; [
+    hunchentoot
+    cl-arrows
+  ];
+  srcs = [
+    ./src/server.lisp
+    injectedPosts
+    injectedExecutables
+  ];
+}