about summary refs log tree commit diff
path: root/advent-of-code/writePythonBin.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-29T14·43+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-29T14·43+0000
commit5c9079a41059e077f2b71b68eb83ff9fcb2e38d1 (patch)
treedce7e3566b04213228fb3c92fc593ca18841d972 /advent-of-code/writePythonBin.nix
parentfb9380ba268b3cd27372acadb87b14cc96163374 (diff)
Splice ./universe directory into ./
Manually merging:
- README.md: I added the description from universe/README.md into the heading of
  dotfiles/README.md.
- .envrc: dotfiles/.envrc was a superset of universe/.envrc
- .gitignore: Adding some of the ignored patterns from universe/.gitignore to
  dotfiles/.gitignore

Everything else here should be a simple rename.
Diffstat (limited to 'advent-of-code/writePythonBin.nix')
-rw-r--r--advent-of-code/writePythonBin.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/advent-of-code/writePythonBin.nix b/advent-of-code/writePythonBin.nix
new file mode 100644
index 000000000000..1730edb2ebe4
--- /dev/null
+++ b/advent-of-code/writePythonBin.nix
@@ -0,0 +1,18 @@
+{ pkgs ? import <nixpkgs> {}, ... }:
+
+{ name, deps, src }:
+
+let
+  inherit (pkgs) pythonPackages writeTextFile;
+  inherit (builtins) toFile;
+
+in writeTextFile {
+  inherit name;
+  executable = true;
+  destination = "/bin/${name}";
+
+  text = ''
+    #!/bin/sh
+    ${pkgs.python3}/bin/python3 ${src}
+  '';
+}