about summary refs log tree commit diff
path: root/advent-of-code/writePythonBin.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-04-05T14·17+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-04-05T14·17+0100
commitb2663788500b0d85527781667b7c2cd6329724ed (patch)
treec6735f5fab1a09215d9e0df5909f42904efc60ea /advent-of-code/writePythonBin.nix
parent444da4aa05cd9ab8c03974413b4f1dfb317148c3 (diff)
Tidy advent-of-code directory
TL;DR:
- Add README.md
- Delete *.nix sketches
- Delete *.pyc and *.ex python artifacts
Diffstat (limited to 'advent-of-code/writePythonBin.nix')
-rw-r--r--advent-of-code/writePythonBin.nix18
1 files changed, 0 insertions, 18 deletions
diff --git a/advent-of-code/writePythonBin.nix b/advent-of-code/writePythonBin.nix
deleted file mode 100644
index 1730edb2ebe4..000000000000
--- a/advent-of-code/writePythonBin.nix
+++ /dev/null
@@ -1,18 +0,0 @@
-{ pkgs ? import <nixpkgs> {}, ... }:
-
-{ name, deps, src }:
-
-let
-  inherit (pkgs) pythonPackages writeTextFile;
-  inherit (builtins) toFile;
-
-in writeTextFile {
-  inherit name;
-  executable = true;
-  destination = "/bin/${name}";
-
-  text = ''
-    #!/bin/sh
-    ${pkgs.python3}/bin/python3 ${src}
-  '';
-}