about summary refs log tree commit diff
path: root/absl/time/CMakeLists.txt
diff options
context:
space:
mode:
authorAbseil Team <absl-team@google.com>2018-10-10T19·31-0700
committerCJ Johnson <johnsoncj@google.com>2018-10-10T19·35-0400
commitf340f773edab951656b19b6f1a77c964a78ec4c2 (patch)
treec42bf7faf49fb2355661c9f39c40513bc1ff2697 /absl/time/CMakeLists.txt
parent445998d7ac4e5d3c50411d377e3b50e960d2d6c2 (diff)
Export of internal Abseil changes.
--
906c47420646d510edd2479d5542c56f5fa31b65 by CJ Johnson <johnsoncj@google.com>:

Import of CCTZ from GitHub.

PiperOrigin-RevId: 216573923

--
74560d4afd2b605909e677c6fc3076049fb3010a by Eric Fiselier <ericwf@google.com>:

Avoid -Wformat-pedantic in benchmark.

PiperOrigin-RevId: 216523769

--
9bcc9da8b03e6d1ea43ee78931256c5541cb9686 by Eric Fiselier <ericwf@google.com>:

Delete unused CityHash functions.

PiperOrigin-RevId: 216464492

--
a42563b394c89fbb4c55cb5a6a5edbf96d271eea by Abseil Team <absl-team@google.com>:

Introduce new Abseil interfaces for converting between civil
times and absolute times.s

Deprecates absl::ConvertDateTime() and absl::FromDateTime().

PiperOrigin-RevId: 216424948

--
088e11235124267517d7f137854fa5554679c24f by Eric Fiselier <ericwf@google.com>:

Remove unneeded break statements in test.

PiperOrigin-RevId: 216403321
GitOrigin-RevId: 906c47420646d510edd2479d5542c56f5fa31b65
Change-Id: Idb44420be623e369c66f5a9c92bdc9ab46d3ec92
Diffstat (limited to 'absl/time/CMakeLists.txt')
-rw-r--r--absl/time/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/absl/time/CMakeLists.txt b/absl/time/CMakeLists.txt
index 06272364f14e..53216cda055b 100644
--- a/absl/time/CMakeLists.txt
+++ b/absl/time/CMakeLists.txt
@@ -15,6 +15,7 @@
 #
 
 list(APPEND TIME_PUBLIC_HEADERS
+  "civil_time.h"
   "clock.h"
   "time.h"
 )
@@ -29,6 +30,7 @@ list(APPEND TIME_INTERNAL_HEADERS
 )
 
 list(APPEND TIME_SRC
+  "civil_time.cc"
   "time.cc"
   "clock.cc"
   "duration.cc"
@@ -74,11 +76,11 @@ absl_library(
 
 # test time_test
 list(APPEND TIME_TEST_SRC
+  "civil_time_test.cc"
   "time_test.cc"
   "clock_test.cc"
   "duration_test.cc"
   "format_test.cc"
-  "time_norm_test.cc"
   "time_test.cc"
   "time_zone_test.cc"
   "internal/test_util.cc"