about summary refs log tree commit diff
path: root/absl/flags/CMakeLists.txt
diff options
context:
space:
mode:
authorAbseil Team <absl-team@google.com>2020-01-10T16·42-0800
committerDerek Mauro <dmauro@google.com>2020-01-10T18·37-0500
commit564001ae506a17c51fa1223684a78f05f91d3d91 (patch)
tree0bda5cd603e93615c83775efae96aeed6cbd7993 /absl/flags/CMakeLists.txt
parentb3aaac8a37c467a1125c794196caa90d0957bdc3 (diff)
Export of internal Abseil changes
--
5448463d79c8473d29b6aae62359eaec09e517b0 by Greg Falcon <gfalcon@google.com>:

Rename absl_types_options.h to absl_alternate_options.h, to reflect that we are testing more than just types with this file.

PiperOrigin-RevId: 289099882

--
8008a5662d1b27c4ea442575405eb0538f63a636 by Abseil Team <absl-team@google.com>:

Internal change

PiperOrigin-RevId: 289097666

--
0e9398fae540bdb7dd752245b83456f3784c50ca by Abseil Team <absl-team@google.com>:

Internal change

PiperOrigin-RevId: 288985613
GitOrigin-RevId: 5448463d79c8473d29b6aae62359eaec09e517b0
Change-Id: I5bc1ee156294793cacf3acbc447c0ea27ce8af4f
Diffstat (limited to 'absl/flags/CMakeLists.txt')
-rw-r--r--absl/flags/CMakeLists.txt29
1 files changed, 28 insertions, 1 deletions
diff --git a/absl/flags/CMakeLists.txt b/absl/flags/CMakeLists.txt
index 7c63821e13eb..20e66825a0aa 100644
--- a/absl/flags/CMakeLists.txt
+++ b/absl/flags/CMakeLists.txt
@@ -27,6 +27,7 @@ absl_cc_library(
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
   DEPS
+    absl::config
     absl::flags_config
     absl::flags_handle
     absl::flags_registry
@@ -47,6 +48,8 @@ absl_cc_library(
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
   DEPS
+    absl::config
+    absl::core_headers
     absl::flags_path_util
     absl::strings
     absl::synchronization
@@ -64,6 +67,7 @@ absl_cc_library(
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
   DEPS
+    absl::config
     absl::strings
   PUBLIC
 )
@@ -81,6 +85,7 @@ absl_cc_library(
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
   DEPS
+    absl::config
     absl::flags_path_util
     absl::flags_program_name
     absl::core_headers
@@ -100,7 +105,9 @@ absl_cc_library(
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
   DEPS
+    absl::config
     absl::core_headers
+    absl::log_severity
     absl::strings
     absl::str_format
 )
@@ -116,6 +123,7 @@ absl_cc_library(
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
   DEPS
+    absl::config
     absl::flags_config
     absl::flags_marshalling
     absl::core_headers
@@ -140,10 +148,10 @@ absl_cc_library(
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
   DEPS
+    absl::config
     absl::flags_config
     absl::flags_handle
     absl::core_headers
-    absl::dynamic_annotations
     absl::raw_logging_internal
     absl::strings
     absl::synchronization
@@ -162,10 +170,12 @@ absl_cc_library(
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
   DEPS
+    absl::config
     absl::flags_config
     absl::flags_handle
     absl::flags_internal
     absl::flags_marshalling
+    absl::flags_registry
     absl::base
     absl::core_headers
     absl::strings
@@ -184,11 +194,14 @@ absl_cc_library(
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
   DEPS
+    absl::config
     absl::flags_config
     absl::flags
     absl::flags_handle
+    absl::flags_internal
     absl::flags_path_util
     absl::flags_program_name
+    absl::flags_registry
     absl::strings
     absl::synchronization
 )
@@ -205,6 +218,8 @@ absl_cc_library(
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
   DEPS
+    absl::config
+    absl::core_headers
     absl::flags_usage_internal
     absl::strings
     absl::synchronization
@@ -223,8 +238,12 @@ absl_cc_library(
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
   DEPS
+    absl::config
+    absl::core_headers
     absl::flags_config
     absl::flags
+    absl::flags_handle
+    absl::flags_internal
     absl::flags_program_name
     absl::flags_registry
     absl::flags_usage
@@ -273,8 +292,12 @@ absl_cc_test(
   COPTS
     ${ABSL_TEST_COPTS}
   DEPS
+    absl::core_headers
     absl::flags
     absl::flags_config
+    absl::flags_handle
+    absl::flags_internal
+    absl::flags_registry
     absl::strings
     gtest_main
 )
@@ -301,6 +324,7 @@ absl_cc_test(
   DEPS
     absl::flags
     absl::flags_parse
+    absl::flags_registry
     absl::raw_logging_internal
     absl::scoped_set_env
     absl::span
@@ -342,6 +366,8 @@ absl_cc_test(
     ${ABSL_TEST_COPTS}
   DEPS
     absl::flags
+    absl::flags_handle
+    absl::flags_marshalling
     absl::flags_registry
     absl::memory
     absl::strings
@@ -376,6 +402,7 @@ absl_cc_test(
     absl::flags_path_util
     absl::flags_program_name
     absl::flags_parse
+    absl::flags_registry
     absl::flags_usage
     absl::memory
     absl::strings