about summary refs log tree commit diff
path: root/absl/debugging/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrien Devresse <adrien.devresse@epfl.ch>2017-10-31T21·15+0100
committerAdrien Devresse <adrien.devresse@epfl.ch>2017-11-02T17·47+0100
commita3322e3bfc96f33d3e195fd38a7c09f263e7e75f (patch)
treee219a8db3dbe4ebba5c8189888e2df12e4db1329 /absl/debugging/CMakeLists.txt
parent200b5a7cb0fb256ab47c933b3150aed91d9d3470 (diff)
Continue CMake support improvement
- Update documentation
- Remove type target
- Remove typos
- simplify target
- improve 1-1 matchign with Bazel targets
Diffstat (limited to 'absl/debugging/CMakeLists.txt')
-rw-r--r--absl/debugging/CMakeLists.txt39
1 files changed, 37 insertions, 2 deletions
diff --git a/absl/debugging/CMakeLists.txt b/absl/debugging/CMakeLists.txt
index 48529a3e2607..57efe80fd05e 100644
--- a/absl/debugging/CMakeLists.txt
+++ b/absl/debugging/CMakeLists.txt
@@ -42,17 +42,52 @@ absl_library(
     absl_stacktrace
   SOURCES
     ${STACKTRACE_SRC}
-  PUBLIC_LIBRARIES
-    ${STACKTRACE_PUBLIC_LIBRARIES}
   EXPORT_NAME
     stacktrace
 )
 
 
+list(APPEND LEAK_CHECK_SRC
+  "leak_check.cc"
+)
+
+
+# leak_check library
+absl_library(
+  TARGET
+    absl_leak_check
+  SOURCES
+    ${LEAK_CHECK_SRC}
+  PUBLIC_LIBRARIES
+    absl_base
+  EXPORT_NAME
+    leak_check
+)
+
+
+# component target
 absl_header_library(
   TARGET
     absl_debugging
+  PUBLIC_LIBRARIES
+    absl_stacktrace absl_leak_check
   EXPORT_NAME
     debugging
 )
 
+#
+## TESTS
+#
+
+# test leak_check_test
+list(APPEND LEAK_CHECK_TEST_SRC "leak_check_test.cc")
+
+absl_test(
+  TARGET
+    leak_check_test
+  SOURCES
+    ${LEAK_CHECK_TEST_SRC}
+  PUBLIC_LIBRARIES
+    absl_leak_check
+)
+