about summary refs log tree commit diff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorAshley Hedberg <ahedberg@google.com>2018-10-22T20·52-0400
committerAshley Hedberg <ahedberg@google.com>2018-10-22T20·54-0400
commitc476da141ca9cffc2137baf85872f0cae9ffa9ad (patch)
tree253e20fa1d03aceeec4b11b767d0985c82f513d1 /absl/container/CMakeLists.txt
parent5fbde92571a269675543b2c513747adb711b0ea1 (diff)
parentc16d5557cd05119b5b7b1318ef778ebe3195b4a1 (diff)
Export of internal Abseil changes.
--
4e043a11b4c10a24e84046827ee16f47e11e35cc by Abseil Team <absl-team@google.com>:

Merge of https://github.com/abseil/abseil-cpp/pull/136

PiperOrigin-RevId: 218197648

--
e61f06e1e601061a443feaa8c5207c52437bd641 by Abseil Team <absl-team@google.com>:

Don't include <iostream> into int128, it's wasteful

Including iostream emits a global constructor for initializing std::cout and
friends, which isn't actually used by this file.

PiperOrigin-RevId: 218156386

--
8a6c82396e4c956be7f285328aec131cb4965f16 by Xiaoyi Zhang <zhangxy@google.com>:

Fix MSVC compiler warnings on discarding return values of functions with 'nodiscard'
attribute.

PiperOrigin-RevId: 217883401

--
abf3e3a0f22bc4070df9dbc9a4ef4d883ed686bf by Tom Manshreck <shreck@google.com>:

Update public README to add new libraries

PiperOrigin-RevId: 217879399

--
43b3b420a4e861711abbfbd497b8f2b3de17ec8c by Abseil Team <absl-team@google.com>:

Import of CCTZ from GitHub.

PiperOrigin-RevId: 217780963

--
1c8831947ca6a65a63842e6bd5f37a7c102a4e1b by Abseil Team <absl-team@google.com>:

Fix typo in a comment (missing comma in usage example).

PiperOrigin-RevId: 217776645
GitOrigin-RevId: 4e043a11b4c10a24e84046827ee16f47e11e35cc
Change-Id: I8999ae928da7a0030b4ecfd8d13da8522fdd013a
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt14
1 files changed, 1 insertions, 13 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 5de75f5936d1..4d2e1554f06a 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -48,11 +48,9 @@ list(APPEND CONTAINER_INTERNAL_HEADERS
 )
 
 
-absl_library(
+absl_header_library(
   TARGET
     absl_container
-  SOURCES
-    "internal/raw_hash_set.cc"
   EXPORT_NAME
     container
 )
@@ -164,13 +162,3 @@ absl_test(
   PUBLIC_LIBRARIES
     ${TEST_INSTANCE_TRACKER_TEST_PUBLIC_LIBRARIES}
 )
-
-
-absl_test(
-  TARGET
-    raw_hash_set_test
-  SOURCES
-    "internal/raw_hash_set_test.cc"
-  PUBLIC_LIBRARIES
-    absl::base absl::hash absl_throw_delegate test_instance_tracker_lib
-)