about summary refs log tree commit diff
path: root/absl/base/CMakeLists.txt
diff options
context:
space:
mode:
authorLászló Nagy <rizsotto@users.noreply.github.com>2020-04-20T20·35+1000
committerGitHub <noreply@github.com>2020-04-20T20·35-0400
commit1a02b7a2054c24f900dab796edb812f9260b51a6 (patch)
tree2ceb7e9661114b1377945bc62edda8b2119536f6 /absl/base/CMakeLists.txt
parentdf60c82df43e33274550e758c7a93fa49f88e0fe (diff)
Use "-lrt" instead of the resolved find_library result when linking librt (#665)
find_library defaults to shared objects
Diffstat (limited to '')
-rw-r--r--absl/base/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/absl/base/CMakeLists.txt b/absl/base/CMakeLists.txt
index 5454992002..a63b591c5f 100644
--- a/absl/base/CMakeLists.txt
+++ b/absl/base/CMakeLists.txt
@@ -191,7 +191,7 @@ absl_cc_library(
     ${ABSL_DEFAULT_COPTS}
   LINKOPTS
     ${ABSL_DEFAULT_LINKOPTS}
-    $<$<BOOL:${LIBRT}>:${LIBRT}>
+    $<$<BOOL:${LIBRT}>:-lrt>
     $<$<BOOL:${MINGW}>:"advapi32">
   DEPS
     absl::atomic_hook