about summary refs log tree commit diff
path: root/absl/CMakeLists.txt
diff options
context:
space:
mode:
authorAbseil Team <absl-team@google.com>2020-02-25T16·48-0800
committerCJ Johnson <johnsoncj@google.com>2020-02-25T18·12-0500
commit0d5ce2797eb695aee7e019e25323251ef6ffc277 (patch)
treee8f17f3202cce51bcb9f25175349b7a61e7ba664 /absl/CMakeLists.txt
parentb69c7d880caddfc25bf348dbcfe9d45fdd8bc6e6 (diff)
Export of internal Abseil changes
--
20405fc394419d434d3ea09b2e62e4edcb282421 by Christian Blichmann <cblichmann@google.com>:

Include `status` subdirectory in main `CMakeLists.txt`

PiperOrigin-RevId: 297125966

--
101087af9689612bdda679ee0869e5cde4472244 by Matt Kulukundis <kfm@google.com>:

Fix typo

PiperOrigin-RevId: 296991360

--
55ff5bc6970d46214c0459d3a7a23973c7dc69b9 by Andy Getzendanner <durandal@google.com>:

Extract logging's ErrnoSaver to absl::base_internal and use it in a couple other places.

PiperOrigin-RevId: 296969168

--
b7cd7550297d53766576f751436617200c65831b by Abseil Team <absl-team@google.com>:

Internal change

PiperOrigin-RevId: 296951474

--
8c04c73fc53f9a09c3e2400812b931157f35fe07 by Andy Soffer <asoffer@google.com>:

Auto-generate list of files in the DLL, and add new build targets to the DLL.

PiperOrigin-RevId: 296932061

--
2f77829e196094f1addefd8ac2ac9e398c5b6100 by Andy Soffer <asoffer@google.com>:

Fix bug introduced by DLL where we couldn't build shared libraries on
non-windows platforms.

Fixes #623

PiperOrigin-RevId: 296919347

--
b768163dbbff0c561b9dff0218a699e5e4fd33f3 by Abseil Team <absl-team@google.com>:

typo: microprosessor

PiperOrigin-RevId: 296904933

--
b185da0dac44c91855373f0723df9242cbfb3db3 by Matthew Brown <matthewbr@google.com>:

Internal cleanup

PiperOrigin-RevId: 296509711
GitOrigin-RevId: 20405fc394419d434d3ea09b2e62e4edcb282421
Change-Id: I55c8eba6f353ceb337455ae144ab743ea21edbef
Diffstat (limited to 'absl/CMakeLists.txt')
-rw-r--r--absl/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/absl/CMakeLists.txt b/absl/CMakeLists.txt
index 26693eadaa..fbfa7822b5 100644
--- a/absl/CMakeLists.txt
+++ b/absl/CMakeLists.txt
@@ -25,6 +25,7 @@ add_subdirectory(memory)
 add_subdirectory(meta)
 add_subdirectory(numeric)
 add_subdirectory(random)
+add_subdirectory(status)
 add_subdirectory(strings)
 add_subdirectory(synchronization)
 add_subdirectory(time)