about summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-09-18T11·01+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-09-18T11·01+0000
commitdf05a759e4b73058ade82b6008c405cc5c75b104 (patch)
treea17d1d17b3323c6c85edc1078eb4d3c094a28dcc /Makefile.am
parentd3de71efc935ac5744dedf22528a6f0c4e38aaf4 (diff)
* In "make init-state", ignore errors creating /nix/store. Hack to
  get the Debian VM builds to work (where /nix/store is a mount point
  containing the store of the host).

Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e8c01a399f..c3f79193a0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,7 @@ init-state:
 	$(INSTALL) $(INIT_FLAGS) $(GROUP_WRITABLE) -d $(DESTDIR)$(localstatedir)/nix/gcroots/channels
 	ln -sfn $(localstatedir)/nix/profiles $(DESTDIR)$(localstatedir)/nix/gcroots/profiles
 	$(INSTALL) $(INIT_FLAGS) -d $(DESTDIR)$(localstatedir)/nix/userpool
-	$(INSTALL) $(INIT_FLAGS) -m 1777 -d $(DESTDIR)$(storedir)
+	-$(INSTALL) $(INIT_FLAGS) -m 1777 -d $(DESTDIR)$(storedir)
 	$(INSTALL) $(INIT_FLAGS) $(GROUP_WRITABLE) -d $(DESTDIR)$(localstatedir)/nix/manifests
 	ln -sfn $(localstatedir)/nix/manifests $(DESTDIR)$(localstatedir)/nix/gcroots/manifests