about summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-11-29T21·06+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-11-29T21·06+0000
commit71e867c5f5ee2c188244da33366e506935abffb7 (patch)
tree9ebf9f95e1af9f70f368a721ad1fb43493a75be2 /Makefile.am
parentc6a97e3b74289fdc8e57189212a0db3d0e6896e0 (diff)
* Remove --enable-setuid, --with-nix-user and --with-nix-group.
  Rather, setuid support is now always compiled in (at least on
  platforms that have the setresuid system call, e.g., Linux and
  FreeBSD), but it must enabled by chowning/chmodding the Nix
  binaries.

Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 5734cbd79d..911f308013 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,10 +20,11 @@ install-data-local: init-state
 	fi
 
 if INIT_STATE
-if SETUID_HACK
-INIT_FLAGS = -g @NIX_GROUP@ -o @NIX_USER@
-GROUP_WRITABLE = -m 775
-endif
+
+# For setuid operation, you can enable the following:
+# INIT_FLAGS = -g @NIX_GROUP@ -o @NIX_USER@
+# GROUP_WRITABLE = -m 775
+
 init-state:
 	$(INSTALL) $(INIT_FLAGS) -d $(DESTDIR)$(localstatedir)/nix
 	$(INSTALL) $(INIT_FLAGS) -d $(DESTDIR)$(localstatedir)/nix/db
@@ -40,6 +41,7 @@ init-state:
 	$(INSTALL) $(INIT_FLAGS) -m 1777 -d $(DESTDIR)$(prefix)/store
 	$(INSTALL) $(INIT_FLAGS) $(GROUP_WRITABLE) -d $(DESTDIR)$(localstatedir)/nix/manifests
 #	$(bindir)/nix-store --init
+
 else
 init-state:
 endif