about summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-11-26T01·13+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-11-26T01·13+0000
commit5d4eb9dd07ddd589ec03582c3eeb82d490023282 (patch)
treecad3a0f498e5105461f105215bc9fbb0aaca1f69 /Makefile.am
parent0c478d2f4d7459c4af4e7608ed45ae3b2f09c7dc (diff)
* Moved the build farm job for building Nix to the Nix tree.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 5 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ea86b1649..45664d6a68 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,17 +1,11 @@
 SUBDIRS = externals src scripts corepkgs doc misc tests
 EXTRA_DIST = substitute.mk nix.spec nix.spec.in bootstrap.sh \
-  svn-revision nix.conf.example NEWS
+  nix.conf.example NEWS
 
 include ./substitute.mk
 
 nix.spec: nix.spec.in
 
-rpm: nix.spec dist
-	rpm $(EXTRA_RPM_FLAGS) -ta $(distdir).tar.gz
-
-relname:
-	echo -n $(distdir) > relname
-
 install-data-local: init-state
 	$(INSTALL) -d $(DESTDIR)$(sysconfdir)/nix
 	$(INSTALL_DATA) $(srcdir)/nix.conf.example $(DESTDIR)$(sysconfdir)/nix
@@ -44,13 +38,11 @@ init-state:
 	ln -sfn $(localstatedir)/nix/manifests $(DESTDIR)$(localstatedir)/nix/gcroots/manifests
 
 else
-init-state:
-endif
 
-svn-revision:
-	svnversion . > svn-revision
+init-state:
 
-all-local: NEWS
+endif
 
-NEWS: doc/manual/NEWS.txt
+NEWS:
+	$(MAKE) -C doc/manual NEWS.txt
 	cp $(srcdir)/doc/manual/NEWS.txt NEWS