about summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-04-22T14·17+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-04-22T14·17+0000
commit759c953196c75b7728bb2d946227f1597b99a4a2 (patch)
treea1d77a4b52e291dac795917ae7e5192b87c410b0 /Makefile.am
parentd7238bc84ebd8356db6d73a80171f1129bbe3d44 (diff)
* Look for GC roots in @localstatedir@/nix/gcroots.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d25ccc5c28..70857e62ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,8 +19,12 @@ init-state:
 	$(INSTALL) -d $(DESTDIR)$(localstatedir)/nix/db
 	$(INSTALL) -d $(DESTDIR)$(localstatedir)/log/nix
 	$(INSTALL) -d $(DESTDIR)$(localstatedir)/nix/profiles
+	$(INSTALL) -d $(DESTDIR)$(localstatedir)/nix/gcroots
+	$(INSTALL) -d $(DESTDIR)$(localstatedir)/nix/gcroots/tmp
+	rm -f $(DESTDIR)$(localstatedir)/nix/gcroots/profiles
+	ln -s $(localstatedir)/nix/profiles $(DESTDIR)$(localstatedir)/nix/gcroots/profiles
 	$(INSTALL) -d $(DESTDIR)$(prefix)/store
 #	$(bindir)/nix-store --init
 else
 init-state:
-endif
\ No newline at end of file
+endif