about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-04-08T14·41+0200
committerVincent Ambo <tazjin@gmail.com>2018-04-08T14·41+0200
commitbea6eb8eb3cf97586155fa4857c6edd6a64fc84e (patch)
tree8c2eb853fcaf4b8e3359ce128cc36fc2c6563051 /Cargo.toml
parent5604d933e89f9020299f59d927d73f2cd12b4134 (diff)
feat(db): Bootstrap DbExecutor actor
Bootstraps an Actix actor carrying DB connections. This actor will be
used to interact with converse's database.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4800dbd02a..b03275ab02 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,5 +7,7 @@ authors = ["Vincent Ambo <mail@tazj.in>"]
 actix = "0.5"
 actix-web = { git="https://github.com/actix/actix-web.git" }
 env_logger = "0.5"
-diesel = { version = "1.2", features = ["postgres", "chrono"]}
+diesel = { version = "1.2", features = ["postgres", "chrono", "r2d2"]}
 chrono = "0.4"
+log = "0.4"
+r2d2 = "*"