about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-04-08T15·30+0200
committerVincent Ambo <tazjin@gmail.com>2018-04-08T15·30+0200
commit3db069c60d5696efc3d8772e07fec65d876b45e2 (patch)
tree31b6cb389d783104b185b5a0ab907e3e9decbad1 /Cargo.toml
parentb83dd99e305f8de13211f14654b7bceb1c6024c1 (diff)
feat(main): Add support for Tera templates
Sets up the structure required to carry Tera templates in the
actix-web state.

The (still very barebones) index renderer has been updated to render a
Tera template.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ecc2fc606f..76dccad89b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,8 +8,10 @@ actix = "0.5"
 actix-web = { git="https://github.com/actix/actix-web.git" }
 env_logger = "0.5"
 diesel = { version = "1.2", features = ["postgres", "chrono", "r2d2"]}
-chrono = "0.4"
+chrono = { version = "0.4", features = ["serde"] }
 log = "0.4"
 r2d2 = "*"
 futures = "*"
 tera = "0.11"
+serde = "1.0"
+serde_derive = "1.0"