about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2019-07-28T02·16-0400
committerGriffin Smith <root@gws.fyi>2019-07-28T02·16-0400
commitf22bcad817ee354b355d29b6b289894e2d15cfaa (patch)
tree509aa3b88f834ffaccd6a90b61ae2c1e1567622d /Cargo.toml
parent68e8ad8a0e6a5ac38b34658f03807ade603a687c (diff)
Add a generic text-prompt system
Add a generic text-prompt system to the Game, and use it to prompt the
character for their name on startup. There's also a Promise type in
util, which is used for the result of the prompt.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b290f6b4442d..f382bc23d7c8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,13 +9,14 @@ backtrace = "0.3"
 clap = {version = "^2.33.0", features = ["yaml"]}
 config = "*"
 downcast-rs = "^1.0.4"
+futures = "0.1.28"
 include_dir = "0.2.1"
 itertools = "*"
 lazy_static = "*"
 log = "*"
 log4rs = "*"
-matches = "0.1.8"
 maplit = "^1.0.1"
+matches = "0.1.8"
 nom = "^5.0.0"
 prettytable-rs = "^0.8"
 proptest = "0.9.3"