about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-04-08T20·36+0200
committerVincent Ambo <tazjin@gmail.com>2018-04-08T20·36+0200
commit249f17b60a0313a66443a5c67403794986430e34 (patch)
treecd73f56fcb822125de967b8486b74f0887256043 /Cargo.toml
parentda33786939979350b58a09145b56913963380c92 (diff)
feat(oidc): Implement initial OIDC actor
Implements an actor that can perform OAuth2 logins (not really
OIDC-compliant yet because Rust doesn't have an easy to use JWT
library that supports JWKS, and I don't have time for that right now).

Currently this hardcodes some Office365-specific stuff.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9bcfafac4f..66babe4167 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,3 +16,9 @@ tera = "0.11"
 serde = "1.0"
 serde_derive = "1.0"
 failure = "*"
+url = "1.7"
+url_serde = "0.2"
+reqwest = "0.8"
+frank_jwt = "3.0"
+serde_json = "1.0"
+hyper = "*"