about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2019-02-26T16·54+0100
committerVincent Ambo <mail@tazj.in>2019-02-26T16·54+0100
commitacc7e64a0d0d26ad2c529b992b96b72f8029d29d (patch)
tree2c88b31b7e9e72ea1b46f5f9bbaaf2dec2cbe55d /Cargo.toml
parentde86cc551a75d37d551f6a7069067c235754b833 (diff)
refactor: Use cURL's own basic auth implementation
Drops the dependency on the base64-crate, which it turns out isn't
necessary as cURL has this built-in.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 1 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7df7f69a25..ae6c325f60 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,12 +9,10 @@ license = "GPL-3.0-or-later"
 repository = "https://github.com/tazjin/crimp"
 
 [features]
-default = [ "json", "basic_auth" ]
+default = [ "json" ]
 json = [ "serde", "serde_json"]
-basic_auth = [ "base64" ]
 
 [dependencies]
 curl = "0.4"
 serde = { version = "1.0", optional = true }
 serde_json = { version = "1.0", optional = true }
-base64 = { version = "0.10", optional = true }