about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2019-02-26T15·44+0100
committerVincent Ambo <mail@tazj.in>2019-02-26T16·30+0100
commitde16d9698db4ea851464d3f3c49f51c97dcbdf03 (patch)
tree2d128ab13cafbcb275842e5101b0aa5b329b1985 /Cargo.toml
parentbd726c7d4c0b32af26d338e6c33f9fb8a7d80171 (diff)
feat: Add optional `Request::basic_auth` utility function
This function adds a dependency on `base64` and is thus gated behind
the (enabled by default) `basic_auth` feature.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 60247f3e666e..175d3424481c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,10 +4,12 @@ version = "0.1.0"
 authors = ["Vincent Ambo <mail@tazj.in>"]
 
 [features]
-default = [ "json" ]
+default = [ "json", "basic_auth" ]
 json = [ "serde", "serde_json"]
+basic_auth = [ "base64" ]
 
 [dependencies]
 curl = "0.4"
 serde = { version = "1.0", optional = true }
 serde_json = { version = "1.0", optional = true }
+base64 = { version = "0.10", optional = true }