about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2017-11-13T13·16+0100
committerKarl Erik Asbjørnsen <karl@asbjornsen.org>2017-11-13T13·23+0100
commitd908fe1cbc7de0bff7cadbe0b3851d50229b7de2 (patch)
tree87789e8fc55f4c9746b5cbd3f9d70189b235bc47 /Cargo.toml
parent2c71e092f69f5cd3c31ad8a84aa4168118579898 (diff)
feat: Add commands to get/set message queue rlimit
When creating a large number of queues the message queue rlimit may be
reached (see mq_overview for details).

This commit adds an `mq rlimit` function that displays the current
rlimits and an optional `--rlimit` flag to the `create` command that
can raise the rlimit when required.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 73d087f69b..7dd3896f93 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,5 +4,7 @@ version = "0.1.0"
 authors = ["Vincent Ambo <tazjin@gmail.com>"]
 
 [dependencies]
-posix_mq = "0.1.1"
 clap = "2.26.2"
+libc = "0.2.32"
+nix = "0.9.0"
+posix_mq = "0.1.1"