about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2019-07-20T01·55-0400
committerGriffin Smith <root@gws.fyi>2019-07-20T01·55-0400
commit29c80ac8ba0d733c6c452d8fd39e9561553495b0 (patch)
treef8384229d84b0d281c2fbbe976aeb5ebc21bdc24 /Cargo.toml
parent4e9138aa6ff72e34392e3467c40d5ddf095f0027 (diff)
Add the beginning of item entities
Add a new Item raw type and entity type, with preliminary, basic support
for food. There's a really frustrating toml-rs bug that prevents writing
these nicely as toml right now, so I also added support for mixing JSON
and TOML in a single config dir
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3de1dbbe8387..b290f6b4442d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,6 +14,7 @@ itertools = "*"
 lazy_static = "*"
 log = "*"
 log4rs = "*"
+matches = "0.1.8"
 maplit = "^1.0.1"
 nom = "^5.0.0"
 prettytable-rs = "^0.8"
@@ -23,6 +24,7 @@ rand = {version = "^0.7.0", features = ["small_rng"]}
 serde = "^1.0.8"
 serde_derive = "^1.0.8"
 serde_json = "*"
+serde_yaml = "0.8"
 termion = "*"
 toml = "^0.5.1"