about summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos O'Ryan <coryan@users.noreply.github.com>2020-01-16T16·04-0500
committerGitHub <noreply@github.com>2020-01-16T16·04-0500
commit52758bec0324a6b120f0bb938f527b1759a0da3d (patch)
tree036e2b7d89f5645b5be7faa25591e2bcaf488453 /CMakeLists.txt
parent20009f59de903d5a70038adee308020a82e3ecad (diff)
feat: add Cloud Pub/Sub protos (#31)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88f3c2a5c9..187a12bf9c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,6 +87,7 @@ set(GOOGLEAPIS_CPP_PROTO_FILES
     "google/cloud/bigquery/v2/model.proto"
     "google/cloud/bigquery/v2/model_reference.proto"
     "google/cloud/bigquery/v2/standard_sql.proto"
+    "google/pubsub/v1/pubsub.proto"
     "google/spanner/admin/database/v1/spanner_database_admin.proto"
     "google/spanner/admin/instance/v1/spanner_instance_admin.proto"
     "google/spanner/v1/keys.proto"
@@ -282,6 +283,18 @@ target_link_libraries(googleapis_cpp_bigtable_protos
                       PRIVATE googleapis_cpp_common_flags)
 
 google_cloud_cpp_grpcpp_library(
+    googleapis_cpp_pubsub_protos
+    "${GOOGLEAPIS_CPP_SOURCE}/google/pubsub/v1/pubsub.proto"
+    PROTO_PATH_DIRECTORIES
+    "${GOOGLEAPIS_CPP_SOURCE}"
+    "${PROTO_INCLUDE_DIR}")
+googleapis_cpp_set_version_and_alias(pubsub_protos)
+target_link_libraries(googleapis_cpp_pubsub_protos
+                      PUBLIC googleapis-c++::api_annotations_protos
+                             googleapis-c++::api_client_protos
+                      PRIVATE googleapis_cpp_common_flags)
+
+google_cloud_cpp_grpcpp_library(
     googleapis_cpp_spanner_protos
     "${GOOGLEAPIS_CPP_SOURCE}/google/spanner/admin/database/v1/spanner_database_admin.proto"
     "${GOOGLEAPIS_CPP_SOURCE}/google/spanner/admin/instance/v1/spanner_instance_admin.proto"
@@ -310,6 +323,7 @@ include(GNUInstallDirs)
 set(googleapis_cpp_installed_libraries_list
     googleapis_cpp_bigtable_protos
     googleapis_cpp_cloud_bigquery_protos
+    googleapis_cpp_pubsub_protos
     googleapis_cpp_spanner_protos
     googleapis_cpp_longrunning_operations_protos
     googleapis_cpp_api_http_protos