about summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvocaviking <vocaviking@users.noreply.github.com>2018-08-08T17·38+0200
committerDerek Mauro <761129+derekmauro@users.noreply.github.com>2018-08-08T17·38-0400
commit29ff6d4860070bf8fcbd39c8805d0c32d56628a3 (patch)
treee1ceccb45cd04f5c2dfadf182e6933e88c286eb0 /CMakeLists.txt
parent083d04dd4a62ebbf037079b06e49b323c5e1192a (diff)
Removed "warning treated as error" flag from MSVC (#153)
* Removed "warning treated as error" flag from MSVC

Setting the "warning treated as error" flag in public projects is problematic, because it can lead to compilation errors for users, when the compiler adds new warnings. This however, does not mean that the project has a bug, only that it emits a new warning. Nevertheless it still fails to compile.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 89a3386f7e..9a7e1031b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,7 +32,7 @@ if (MSVC)
   # /wd4244  conversion from 'type1' to 'type2'
   # /wd4267  conversion from 'size_t' to 'type2'
   # /wd4800  force value to bool 'true' or 'false' (performance warning)
-  add_compile_options(/W3 /WX /wd4005 /wd4068 /wd4244 /wd4267 /wd4800)
+  add_compile_options(/W3 /wd4005 /wd4068 /wd4244 /wd4267 /wd4800)
   add_definitions(/DNOMINMAX /DWIN32_LEAN_AND_MEAN=1 /D_CRT_SECURE_NO_WARNINGS /D_SCL_SECURE_NO_WARNINGS)
 else()
   set(ABSL_STD_CXX_FLAG "-std=c++11" CACHE STRING "c++ std flag (default: c++11)")