about summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos O'Ryan <coryan@google.com>2019-08-15T12·51-0400
committerCarlos O'Ryan <coryan@google.com>2019-08-15T12·51-0400
commit22b90b89b9f33d394b26b0b03655a7325c598de6 (patch)
tree548c09bfefbdff56c94b023fea314f04335f8fee /CMakeLists.txt
parent8c2add05fa9f3cf83ff7acfba61090d07e67f6fc (diff)
feat: Add library for api/client.proto.
Also fixed the list of libraries in googleapis-config.cmake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0914a89bb8..37c38002e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,6 +61,7 @@ ExternalProject_Add(
         "${GOOGLEAPIS_CPP_SOURCE}/google/api/http.proto"
         "${GOOGLEAPIS_CPP_SOURCE}/google/api/annotations.proto"
         "${GOOGLEAPIS_CPP_SOURCE}/google/api/auth.proto"
+        "${GOOGLEAPIS_CPP_SOURCE}/google/api/client.proto"
         "${GOOGLEAPIS_CPP_SOURCE}/google/api/resource.proto"
         "${GOOGLEAPIS_CPP_SOURCE}/google/type/expr.proto"
         "${GOOGLEAPIS_CPP_SOURCE}/google/rpc/error_details.proto"
@@ -149,6 +150,16 @@ target_link_libraries(googleapis_cpp_api_auth_protos
                       PRIVATE googleapis_cpp_common_flags)
 
 google_cloud_cpp_grpcpp_library(
+    googleapis_cpp_api_client_protos
+    "${GOOGLEAPIS_CPP_SOURCE}/google/api/client.proto"
+    PROTO_PATH_DIRECTORIES
+    "${GOOGLEAPIS_CPP_SOURCE}"
+    "${PROTO_INCLUDE_DIR}")
+googleapis_cpp_set_version_and_alias(api_client_protos)
+target_link_libraries(googleapis_cpp_api_client_protos
+                      PRIVATE googleapis_cpp_common_flags)
+
+google_cloud_cpp_grpcpp_library(
     googleapis_cpp_api_resource_protos
     "${GOOGLEAPIS_CPP_SOURCE}/google/api/resource.proto"
     PROTO_PATH_DIRECTORIES