about summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos O'Ryan <coryan@google.com>2019-08-23T14·17-0400
committerCarlos O'Ryan <coryan@google.com>2019-08-23T14·17-0400
commit7e50ad50b84ed6098060531e8980a2925323bc9b (patch)
treec09a783e7da0b5f0c6627bc6a0e0363ef57298c9 /CMakeLists.txt
parent7420d536eaa2e659e9b19bac6c5ecdb2efeb0bbf (diff)
chore: Irregularly scheduled update for the protos.
Update to the version of googleapis/googleapis as-of 2019-08-23.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 16 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea6e098673..78fbb7bf33 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,10 +39,10 @@ set(CMAKE_CXX_STANDARD_REQUIRED ON)
 # downloaded from GitHub.
 set(
     GOOGLE_CLOUD_CPP_GOOGLEAPIS_URL
-    "https://github.com/googleapis/googleapis/archive/a8ee1416f4c588f2ab92da72e7c1f588c784d3e6.tar.gz"
+    "https://github.com/googleapis/googleapis/archive/9c9f778aedde02f9826d2ae5d0f9c96409ba0f25.tar.gz"
     )
 set(GOOGLE_CLOUD_CPP_GOOGLEAPIS_SHA256
-    "6b8a9b2bcb4476e9a5a9872869996f0d639c8d5df76dd8a893e79201f211b1cf")
+    "13af135d8cc9b81b47d6fbfc258fe790a151956d06e01fd16671aa49fe536ab1")
 
 set(GOOGLEAPIS_CPP_SOURCE
     "${CMAKE_BINARY_DIR}/external/googleapis/src/googleapis_download")
@@ -68,6 +68,7 @@ ExternalProject_Add(
         "${GOOGLEAPIS_CPP_SOURCE}/google/type/expr.proto"
         "${GOOGLEAPIS_CPP_SOURCE}/google/rpc/error_details.proto"
         "${GOOGLEAPIS_CPP_SOURCE}/google/rpc/status.proto"
+        "${GOOGLEAPIS_CPP_SOURCE}/google/iam/v1/options.proto"
         "${GOOGLEAPIS_CPP_SOURCE}/google/iam/v1/policy.proto"
         "${GOOGLEAPIS_CPP_SOURCE}/google/iam/v1/iam_policy.proto"
         "${GOOGLEAPIS_CPP_SOURCE}/google/longrunning/operations.proto"
@@ -203,6 +204,17 @@ target_link_libraries(googleapis_cpp_rpc_status_protos
                       PRIVATE googleapis_cpp_common_flags)
 
 google_cloud_cpp_grpcpp_library(
+    googleapis_cpp_iam_v1_options_protos
+    "${GOOGLEAPIS_CPP_SOURCE}/google/iam/v1/options.proto"
+    PROTO_PATH_DIRECTORIES
+    "${GOOGLEAPIS_CPP_SOURCE}"
+    "${PROTO_INCLUDE_DIR}")
+googleapis_cpp_set_version_and_alias(iam_v1_options_protos)
+target_link_libraries(googleapis_cpp_iam_v1_options_protos
+                      PUBLIC googleapis-c++::api_annotations_protos
+                      PRIVATE googleapis_cpp_common_flags)
+
+google_cloud_cpp_grpcpp_library(
     googleapis_cpp_iam_v1_policy_protos
     "${GOOGLEAPIS_CPP_SOURCE}/google/iam/v1/policy.proto"
     PROTO_PATH_DIRECTORIES
@@ -321,6 +333,7 @@ set(googleapis_cpp_installed_libraries_list
     googleapis_cpp_api_resource_protos
     googleapis_cpp_devtools_cloudtrace_v2_trace_protos
     googleapis_cpp_devtools_cloudtrace_v2_tracing_protos
+    googleapis_cpp_iam_v1_options_protos
     googleapis_cpp_iam_v1_policy_protos
     googleapis_cpp_iam_v1_iam_policy_protos
     googleapis_cpp_rpc_error_details_protos
@@ -407,6 +420,7 @@ set(GOOGLE_CLOUD_CPP_PC_DESCRIPTION
 string(CONCAT GOOGLE_CLOUD_CPP_PC_REQUIRES
               "googleapis_cpp_bigtable_protos"
               " googleapis_cpp_iam_v1_iam_policy_protos"
+              " googleapis_cpp_iam_v1_options_protos"
               " googleapis_cpp_iam_v1_policy_protos"
               " googleapis_cpp_longrunning_operations_protos"
               " googleapis_cpp_api_auth_protos"