about summary refs log tree commit diff
path: root/users/wpcarro/website/blog/default.nix
{ pkgs, ... }:

pkgs.stdenv.mkDerivation {
  name = "blog.wpcarro.dev";
  buildInputs = with pkgs; [ hugo ];
  src = builtins.path { path = ./.; name = "blog"; };
  buildPhase = ''
    mkdir -p $out
    ${pkgs.hugo}/bin/hugo --minify --destination $out
  '';
  dontInstall = true;
}