about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-merge-nested-rec-attrs.nix
{
  set = rec {
    a = 21;
  };

  set = {
    # Fun fact: This might be the only case in Nix where a lexical
    # resolution of an identifier can only be resolved by looking at
    # *siblings* in the AST.
    b = 2 * a;
  };
}