about summary refs log tree commit diff
path: root/third_party/git/default.nix
# Use the upstream git derivation (there's a lot of stuff happening in
# there!) and just override the source:
{ pkgs, ... }:

(pkgs.git.overrideAttrs(_: {
  version = "2.29.2";
  src = ./.;
  doInstallCheck = false;
  preConfigure = ''
    ${pkgs.autoconf}/bin/autoreconf -i
  '';
})).override {
  sendEmailSupport = true;
}