about summary refs log tree commit diff
path: root/ops/nixos/www/todo.tvl.fyi.nix
{ config, ... }:

{
  imports = [
    ./base.nix
  ];

  config = {
    services.nginx.virtualHosts."todo.tvl.fyi" = {
      serverName = "todo.tvl.fyi";
      root = config.depot.web.todolist;
      enableACME = true;
      forceSSL = true;

      extraConfig = ''
        add_header Strict-Transport-Security "max-age=31536000; includeSubDomains; preload" always;

        location ~* \.(webp|woff2)$ {
          add_header Cache-Control "public, max-age=31536000";
        }
      '';
    };
  };
}