about summary refs log tree commit diff
path: root/ops/buildkite/default.nix
{ depot, lib, pkgs, ... }:

depot.nix.readTree.drvTargets rec {
  terraform = pkgs.terraform.withPlugins (p: [
    p.buildkite
  ]);

  validate = depot.tools.checks.validateTerraform {
    inherit terraform;
    name = "buildkite";
    src = lib.cleanSource ./.;
    env.BUILDKITE_API_TOKEN = "ci-dummy";
  };
}