about summary refs log tree commit diff
path: root/nix/runExecline/default.nix
{ depot, pkgs, lib, ... }:
let
  runExecline = import ./runExecline.nix {
    inherit (pkgs) stdenv;
    inherit (depot.nix) escapeExecline getBins;
    inherit pkgs lib;
  };

  tests = import ./tests.nix {
    inherit runExecline;
    inherit (depot.nix) getBins writeScript;
    inherit (pkgs) stdenv coreutils;
    inherit pkgs;
  };

in {
  __functor = _: runExecline;
  inherit tests;
}