about summary refs log tree commit diff
path: root/views/tvix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'views/tvix/default.nix')
-rw-r--r--views/tvix/default.nix14
1 files changed, 1 insertions, 13 deletions
diff --git a/views/tvix/default.nix b/views/tvix/default.nix
index 28e51c28b4..33d6b63686 100644
--- a/views/tvix/default.nix
+++ b/views/tvix/default.nix
@@ -9,17 +9,6 @@
 , ...
 }:
 
-let
-  # `Call $methodName --bytes-as-base64` support for evans
-  evans = pkgs.evans.overrideAttrs (old: {
-    patches = old.patches or [ ] ++ [
-      (pkgs.fetchpatch {
-        url = "https://github.com/ktr0731/evans/pull/611/commits/f2109627c0d20588980fe6fd6348d223dbdf7c33.patch";
-        hash = "sha256-ff8drvAYwQvHeymaHEruvwDYynClpzPM5lrB7IeQHBs=";
-      })
-    ];
-  });
-in
 pkgs.mkShell {
   name = "tvix-rust-dev-env";
   packages = [
@@ -30,7 +19,6 @@ pkgs.mkShell {
     pkgs.rustc
     pkgs.rustfmt
     pkgs.protobuf
-
-    evans
+    pkgs.evans
   ];
 }