about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
new file mode 100644
index 0000000000..5b10748f3d
--- /dev/null
+++ b/tvix/default.nix
@@ -0,0 +1,14 @@
+# Nix helpers for projects under //tvix
+
+{ pkgs, ... }:
+
+{
+  # Construct a sparse tree for naersk's `root` field, for
+  # compatibility with the workspace-workaround (see top-level comment
+  # in //tvix/Cargo.toml)
+  naerskRootFor = cargoToml: pkgs.runCommand "sparse-tvix-root" { } ''
+    mkdir $out
+    cp -aT ${./Cargo.lock} $out/Cargo.lock
+    cp -aT ${cargoToml} $out/Cargo.toml
+  '';
+}