about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix14
1 files changed, 5 insertions, 9 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index 5b10748f3d..7225bfb89e 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -1,14 +1,10 @@
 # Nix helpers for projects under //tvix
-
 { pkgs, ... }:
 
 {
-  # Construct a sparse tree for naersk's `root` field, for
-  # compatibility with the workspace-workaround (see top-level comment
-  # in //tvix/Cargo.toml)
-  naerskRootFor = cargoToml: pkgs.runCommand "sparse-tvix-root" { } ''
-    mkdir $out
-    cp -aT ${./Cargo.lock} $out/Cargo.lock
-    cp -aT ${cargoToml} $out/Cargo.toml
-  '';
+  # Load the crate2nix crate tree.
+  crates = import ./Cargo.nix {
+    inherit pkgs;
+    nixpkgs = pkgs.path;
+  };
 }