about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index 3365fe7981..28e64d574a 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -111,12 +111,10 @@ in
     (cd $(git rev-parse --show-toplevel)/tvix/castore-go && rm *.pb.go && cp ${depot.tvix.castore.protos.go-bindings}/*.pb.go . && chmod +w *.pb.go)
   '';
 
-  # Builds and tests the code in store/protos.
-  store-protos-go = pkgs.buildGoModule {
-    name = "store-golang";
-    src = depot.third_party.gitignoreSource ./store/protos;
-    vendorHash = "sha256-WAYaIT3h3Cdvo1RB8T7DuoxeKvXfkq8vo/vdkhJQDs0=";
-  };
+  # Update `.pb.go` files in tvix/store-go with the generated ones.
+  store-go-generate = pkgs.writeShellScriptBin "store-go-protogen" ''
+    (cd $(git rev-parse --show-toplevel)/tvix/store-go && rm *.pb.go && cp ${depot.tvix.store.protos.go-bindings}/*.pb.go . && chmod +w *.pb.go)
+  '';
 
   # Build the Rust documentation for publishing on docs.tvix.dev.
   rust-docs = pkgs.stdenv.mkDerivation {
@@ -144,7 +142,6 @@ in
   };
 
   meta.ci.targets = [
-    "store-protos-go"
     "shell"
     "rust-docs"
   ];