about summary refs log tree commit diff
path: root/tools/nixery/popcount/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/nixery/popcount/default.nix')
-rw-r--r--tools/nixery/popcount/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/tools/nixery/popcount/default.nix b/tools/nixery/popcount/default.nix
new file mode 100644
index 0000000000..4a3c8faf9c
--- /dev/null
+++ b/tools/nixery/popcount/default.nix
@@ -0,0 +1,26 @@
+# Copyright 2019 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+{ go, stdenv }:
+
+stdenv.mkDerivation {
+  name = "nixery-popcount";
+
+  buildInputs = [ go ];
+  phases = [ "buildPhase" ];
+  buildPhase = ''
+    mkdir -p $out/bin
+    go build -o $out/bin/popcount ${./popcount.go}
+  '';
+}