about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix22
1 files changed, 9 insertions, 13 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 60f6360a2c..950c01798f 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -45,12 +45,15 @@ depot.nix.readTree.drvTargets {
     ];
   });
 
-  # Apply workaround from https://github.com/NixOS/nixpkgs/pull/211469
-  # until it hits the nixos-unstable channel
-  mullvad = super.mullvad.overrideAttrs (old: {
-    nativeBuildInputs = old.nativeBuildInputs ++ [
-      self.buildPackages.git
-    ];
+  # Too match telega in emacs-overlay or wherever
+  tdlib = super.tdlib.overrideAttrs (_: {
+    version = "1.8.11";
+    src = self.fetchFromGitHub {
+      owner = "tdlib";
+      repo = "td";
+      rev = "1543c41f3411bd6aa74713c8aba4e93fa8d952c7";
+      sha256 = "0qw3a2wh5hfad0m4ixywh5p2mvyprkw982jb7n4sqxdvwc0xfcgq";
+    };
   });
 
   home-manager = super.home-manager.overrideAttrs (_: {
@@ -100,13 +103,6 @@ depot.nix.readTree.drvTargets {
     };
   });
 
-  # `Call $methodName --bytes-as-base64` support for evans
-  evans = super.evans.overrideAttrs (old: {
-    patches = old.patches or [ ] ++ [
-      ./patches/evans-add-support-for-bytes-as-base64.patch
-    ];
-  });
-
   # nix-serve does not work with nix 2.4
   # https://github.com/edolstra/nix-serve/issues/28
   nix-serve = super.nix-serve.override { nix = super.nix_2_3; };