about summary refs log tree commit diff
path: root/users/wpcarro/nixos/modules/www/billandhiscomputer.com.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/nixos/modules/www/billandhiscomputer.com.nix')
-rw-r--r--users/wpcarro/nixos/modules/www/billandhiscomputer.com.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/users/wpcarro/nixos/modules/www/billandhiscomputer.com.nix b/users/wpcarro/nixos/modules/www/billandhiscomputer.com.nix
new file mode 100644
index 0000000000..ec4e5d7302
--- /dev/null
+++ b/users/wpcarro/nixos/modules/www/billandhiscomputer.com.nix
@@ -0,0 +1,11 @@
+{ pkgs, depot, ... }:
+
+{
+  config = {
+    services.nginx.virtualHosts."billandhiscomputer.com" = {
+      enableACME = true;
+      forceSSL = true;
+      root = depot.users.wpcarro.website.root;
+    };
+  };
+}