about summary refs log tree commit diff
path: root/users/tazjin/home/shared.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/home/shared.nix')
-rw-r--r--users/tazjin/home/shared.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/users/tazjin/home/shared.nix b/users/tazjin/home/shared.nix
index c80a10945fa3..5cbc4b98f068 100644
--- a/users/tazjin/home/shared.nix
+++ b/users/tazjin/home/shared.nix
@@ -5,6 +5,8 @@
 
 
 let
+  inherit (depot.third_party) chicago95;
+
   # URL handler to open `tg://` URLs in telega.el
   telega-launcher = pkgs.writeShellScriptBin "telega-launcher" ''
     echo "Opening ''${1} in telega.el ..."
@@ -91,6 +93,18 @@ in
     '';
   };
 
+  gtk = {
+    enable = true;
+    theme.name = "Chicago95";
+    theme.package = chicago95;
+
+    iconTheme.name = "Chicago95-tux";
+    iconTheme.package = chicago95;
+
+    cursorTheme.name = "Chicago95_Animated_Hourglass_Cursors_HiDPI";
+    cursorTheme.package = chicago95;
+  };
+
   systemd.user.startServices = true;
 
   # Previous default version, see https://github.com/nix-community/home-manager/blob/master/docs/release-notes/rl-2211.adoc