about summary refs log tree commit diff
path: root/users/glittershark/system/home/modules/development/agda.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/modules/development/agda.nix')
-rw-r--r--users/glittershark/system/home/modules/development/agda.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/users/glittershark/system/home/modules/development/agda.nix b/users/glittershark/system/home/modules/development/agda.nix
index 7a197e907f..bed05693aa 100644
--- a/users/glittershark/system/home/modules/development/agda.nix
+++ b/users/glittershark/system/home/modules/development/agda.nix
@@ -1,10 +1,7 @@
 { config, lib, pkgs, ... }:
 
 let
-
-  nixpkgs-unstable = import <nixpkgs-unstable> {};
-
-  agda-categories = with nixpkgs-unstable.agdaPackages; mkDerivation rec {
+  agda-categories = with pkgs.agdaPackages; mkDerivation rec {
     pname = "agda-categories";
     version = "2128fab";
     src = pkgs.fetchFromGitHub {
@@ -25,7 +22,7 @@ in
   ];
 
   home.packages = with pkgs; [
-    (nixpkgs-unstable.agda.withPackages
+    (pkgs.agda.withPackages
       (p: with p; [
         p.standard-library