about summary refs log tree commit diff
path: root/users/glittershark/system/home/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/default.nix')
-rw-r--r--users/glittershark/system/home/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/users/glittershark/system/home/default.nix b/users/glittershark/system/home/default.nix
new file mode 100644
index 0000000000..762b8a6656
--- /dev/null
+++ b/users/glittershark/system/home/default.nix
@@ -0,0 +1,26 @@
+{ pkgs, depot, lib, ... }:
+
+with lib;
+
+rec {
+  nixpkgs = import pkgs.nixpkgsSrc {};
+
+  home-manager = (fetchTarball {
+    url = "https://github.com/rycee/home-manager/archive/5f189acce44dc39ea4055bfd8064adaf90d7fb5a.tar.gz";
+    sha256 = "0ibmvg3k9m9yzh8ln3jlh47nrvgg81iy8gpl112wjimlp6gagxw6";
+  });
+
+  home = confPath: import "${home-manager}/modules" {
+    pkgs = nixpkgs;
+    configuration = { config, lib, ... }: {
+      imports = [confPath];
+
+      _module.args.pkgs = mkForce
+        (import pkgs.nixpkgsSrc (filterAttrs (n: v: v != null) config.nixpkgs));
+
+      lib.depot = depot;
+    };
+  };
+
+  chupacabra = home ./machines/chupacabra.nix;
+}